请选择 进入手机版 | 继续访问电脑版

简码阁

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 163|回复: 3

[已解决] 求帮助一个大漠插件绑定窗口的问题

[复制链接]

该用户从未签到

发表于 2021-7-8 16:11:06 | 显示全部楼层 |阅读模式
调用大漠插件时,程序运行到BindWindow时,控制台直接显示“被调试易程序运行完毕”,然后就退出了。
主要程序如下:
.版本 2
.支持库 spec

mainFramePointer = dm.FindWindow (“LDPlayerMainFrame”, “”)

.如果真 (mainFramePointer = 0)
    运行 (编辑框_程序路径.内容, 假, )
    延迟 (15000)
.如果真结束

mainFramePointer = dm.FindWindow (“LDPlayerMainFrame”, “”)
renderWindowPointer = dm.FindWindowEx (mainFramePointer, “RenderWindow”, “”)
subWinPointer = dm.FindWindowEx (renderWindowPointer, “subWin”, “”)
调试输出 (subWinPointer)

bindSuccess = dm.BindWindow (mainFramePointer, “gdi”, “windows”, “windows”, 0)
调试输出 (bindSuccess)




点击开始,会运行查找窗口,与绑定窗口操作,但到BindWindow时,就出现上面描述的情况。
执行结果如下:
* “7.2053”
* 199952
被调试易程序运行完毕


检查过:
1. 系统用户账户有Administrator权限
2.系统防火墙都已关闭,且没有安装杀毒软件,360任何软件都未安装
3.vbs脚本权限正常



简码阁全面专业的原创中文编程网站
  • TA的每日心情

    2021-1-31 01:02
  • 签到天数: 3 天

    [LV.2]偶尔看看I

    发表于 2021-7-9 20:14:46 | 显示全部楼层
    因为你用的是7.2053 这属于收费版本的大漠.所以 在你没有注册大漠VIP的情况下,调用绑定函数直接崩
    简码阁全面专业的原创中文编程网站
    回复

    使用道具 举报

    该用户从未签到

    发表于 2021-7-12 22:35:26 | 显示全部楼层
    admin 发表于 2021-7-9 20:14
    因为你用的是7.2053 这属于收费版本的大漠.所以 在你没有注册大漠VIP的情况下,调用绑定函数直接崩 ...

    我也是这个问题.这个用破解版的也没用吗,其他VPN函数都不影响,就这个不行
    简码阁全面专业的原创中文编程网站
    回复

    使用道具 举报

  • TA的每日心情

    2021-1-31 01:02
  • 签到天数: 3 天

    [LV.2]偶尔看看I

    发表于 2021-7-13 04:45:27 | 显示全部楼层
    cbh30038331 发表于 2021-7-12 22:35
    我也是这个问题.这个用破解版的也没用吗,其他VPN函数都不影响,就这个不行 ...

    破解的也是需要调用注册VIP函数并保证是成功的才可以
    简码阁全面专业的原创中文编程网站
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

     
     
    VIP咨询
    VIP办理
    交流1群:
    易语言脚本交流
    工作时间:
    10:00-20:00

    QQ|Archiver|手机版|小黑屋|简码阁 ( 苏ICP备16034616号-2 )

    GMT+8, 2021-7-30 11:40 , Processed in 0.195985 second(s), 38 queries .

    Powered by Discuz! X3.4

    Copyright © 2001-2020, Tencent Cloud.

    快速回复 返回顶部 返回列表